How do I align the FY Correctly so that 10/1/2020 = the start of FY2021?

2.62K viewsformatting Timeline

Currently the FY is set to start on OCT, however the years do not properly align, the years are behind.

Answered question

Is anyone else seeing my question? I just want to make I posted correctly! Thanks


The fiscal year feature is unfortunately useless for a large number of applications as it is pretty common for the next fiscal year to start during the present calendar year (e.g. the fiscal year is one year ahead, so FY 22 will start in calendar year 21 in some month.)

The problem with the xViz fiscal year feature is it assumes that the fiscal year that is starting is the same as the calendar year and there is no option to designate if FY is ahead or behind calendar. I am not an accountant, but I don’t think lagging FY is too common, if used at all.  Is it even allowed by GAAP? IDK.

WARNING: The user posted work arounds to try and use the Zoom levels (edit visual, Zoom Levels) immediately triggers the xViz Upgrade to a Pro License pop up and you can’t undo it even if you try and “undo” your zoom levels, you have to re-write your visual.  Even if you are using Pro FY (so no pop ups) still doesn’t work but you might be able to hide it by turning off the years in the timeline.

It’s difficult to justify a license when basic stuff doesn’t even work.

Edited answer

Greetings medwards!
I tried something yesterday after posting and things are a bit better with the layout today.
There is a screenshot attached and I’ve blocked out all of the names for company’s sake.
However, you can clearly see at least the date range is lining up better.
Prior to this attempt instead of 2019 at the beginning of the timeline it showed 2018!
As mentioned before none of the start dates in our database have 2018 in them at all!

Please note: This update isn’t perfect – but it’s much better than before!
At least the dates are lining up now – but when I try to shift the fiscal year start month to October – things still go ‘off the rails’ – I would consider that feature to still be buggy.
For example: If I set the fiscal year start to October – the entire timeline shifts again to put January 2018 back as the start-point – for now I’m leaving it to January. <shrug>

Steps I took:
I made sure I wasn’t logged in anywhere to the xviz site and went through the following link:

Gantt Chart – Enterprise

Goto the FREE section on the left and hit the ‘Get It Free’ button.
Pop in your Email and the Download will start.
The most recent copy that I received yesterday was:


Under the Visualizations section in PowerBI for xviz goto: Format –> Timeline
I set the following: Enable Top-Level in Timeline ‘On’, Enable Mid-Level in Timeline ‘On’, Enable Low-Level in Timeline ‘Off’.

I also went in to the ‘edit’ section on the report itself to ‘ZoomLevels’ and set:
Top Level = Year (1), Middle Level = Month (1), Bottom Level = Week (7)
*However, week is not shown due to turning that off in the Format section as mentioned before.

I hope this might come of some use to you and like you say – hopefully dev is OK and more updates are coming!


Edited answer

Greetings, I see your post and am experiencing the same exact issue!

The earliest date of any of our listed projects is Jan 07th 2019. However, the timeline above has 2018 listed as the start time.

I even attempted to filter out any items that had ‘blank’ as a start date – and even went as far as making a copy of the database and deleting them all to rule this out as an issue.

I’ve also toyed around with trying to manipulate the fiscal start as ours is also OCT to no success.

This visual for PowerBI seems to have a lot of potential but being unable to control basic items like a correct timeline make this a showstopper.

Posted new comment

Well, I have no work around, other than in my particular situation, and the way I am currently sharing info (cut and paste to .ppt – don’t ask), I just crop the year out of the top.

I do hope that the developer does not have COVID, and will be able to reconcile a solution!!